criticalCVE-2026-111497CVSS 9.8

Node.js Brotli Request-Body Integer Overflow (node2shell) - Remote Code Execution

Could your systems be exposed to this vulnerability?

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Enter a domain or public IP you own. We'll check for signs of exposure. No signup required.

No signup. No installation. Results in about a minute.

Recommended remediation

Update to version 1.0.10, 1.1.1, 1.2.1 or latest available version.

Tags

cvecve2026nodejsexpressbrotlioverflowrcenode2shelljsvkevkev