criticalCVE-2021-44228CVSS 10

Apache Log4j2 Remote Code Injection

Could your systems be exposed to this vulnerability?

Apache Log4j2 <=2.14.1 JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers when message lookup substitution is enabled.

Enter a domain or public IP you own. We'll check for signs of exposure. No signup required.

No signup. No installation. Results in about a minute.

Recommended remediation

Upgrade to Log4j 2.3.1 (for Java 6), 2.12.3 (for Java 7), or 2.17.0 (for Java 8 and later).

Tags

cve2021cverceoastlog4jinjectionkevapachevkevvuln